Password Reset and Changing Issues

Incident Report for Floify

Resolved

We have implemented a fix and users should be able to change their password as needed moving forward.
Posted Apr 14, 2026 - 13:54 MDT

Investigating

We are investigating reports of borrower and realtor accounts having difficulty changing or resetting passwords.
Posted Apr 14, 2026 - 11:33 MDT
This incident affected: System.