SMS Delivery Issues

Incident Report for Floify

Resolved

This issue has been resolved and we have seen service restored in full.
Posted Dec 02, 2025 - 08:58 MST

Monitoring

We are seeing improvement to delivery from most networks. There are still some reports of delay, but have received notice from Twilio of improvements to performance.

If you are trying to receive the MFA text message, please give the network a few minutes if you have not received it.
Posted Dec 01, 2025 - 14:59 MST

Identified

Our SMS provider, Twilio, has reported delays for SMS messaging, which may impact outbound messaging from our system, including Multi-Factor Authentication (MFA).

We are working with our partners to monitor the resolution of the issue and will post updates. In the meantime, if you need help accessing your account, please follow the standard MFA process. We recommend setting your MFA method to have both email and SMS options to ensure access.
Posted Dec 01, 2025 - 10:53 MST
This incident affected: System.